Important: for security reasons, TLS encryption v1.0 and v1.1 are being disabled across all accounts which will result in the following pages and services being inaccessible:

Intermedia is changing the Transport Layer Security (TLS) policies for its web-based interfaces by disabling TLS 1.0 and 1.1. This action will require all customers to connect via TLS 1.2 or higher.

This article provides the necessary information for this change, and we will be updating it as new information become available.

What is Transport Layer Security?

TLS is a protocol that provides data-in-motion security by helping to ensure confidentiality and integrity between applications communicating over a public network, such as the Internet. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification. The versions of TLS, to date, are TLS 1.0, 1.1, 1.2 and 1.3.

Why this is happening?

Updating security protocols is part of the regular business cycle that allows us to continually improve our security and maintain those protections. Intermedia is now enforcing TLS 1.2 or higher encryption protocol in an effort to maintain the security standards that align with industry practices, help ensure compliance with regulations, and promote the safety of customer data.

What do I need to do?

Please follow the instructions below to prevent any disruptions in your access to CONTROL PANEL and PowerShell.

Partner Portal, CONTROL PANEL, My Services, OWA

Use the following link to check if your browser supports TLS 1.2 and higher.

In case TLS 1.2 or higher is not supported, update your web browser to the latest version available. The latest version Firefox®, Google Chrome™, Internet Explorer®, and Safari® support the safe version of TLS and will not be affected by this change.

Note: TLS v1.2 is supported since

  • Chrome 30 (2013-08-20)
  • Firefox 27 (2014-02-04)
  • IE 11 (2013-11-17)
  • Safari 7 (2013-11-22)
  • Opera 17 (2013-10-13)
  • iOS Safari 5.1 (2012-03-07)

CONTROL PANEL PowerShell Access

If you're using Windows 7 SP1, Windows Server 2008 R2 SP1 or Windows Server 2012, go to the Microsoft article to install Windows update and edit registry keys with Easy Fix tool.

To continue using CONTROL PANEL PowerShell on newer OS versions, make sure that the latest Windows updates are installed. If CONTROL PANEL PowerShell still fails to connect, follow these instructions.

CONTROL PANEL API

Check to see if the API client software(s)/frameworks are configured to support TLS 1.2 and above.